Support

If you have a problem or need to report a bug please email : support@dsprobotics.com

There are 3 sections to this support area:

DOWNLOADS: access to product manuals, support files and drivers

HELP & INFORMATION: tutorials and example files for learning or finding pre-made modules for your projects

USER FORUMS: meet with other users and exchange ideas, you can also get help and assistance here

Any info on Flowstone versioning?

For general discussion related FlowStone

Any info on Flowstone versioning?

Postby snafu » Mon Jun 10, 2019 9:26 pm

Hi there,

it's been a while, and only recently I have returned to flowstone. In my download area it says 'YOUR UPGRADE COVER HAS EXPIRED'. I think I started with version 3.0.7, but I'm not sure though. I can download anything from 3.0 to 3.0.9beta, so I wasn't sure if it is actually the newest version. There have been a few issues with the version I used before, so I wanted to upgrade. So, I've been around here for a good two hours now, and now confusion kicks in:
- if I can download 3.0.8 (or any of the betas), which seem to be the latest versions, there's no need upgrading for me, isn't it?
- is Flowstone still updated? The latest version seems to date back to 2016 - or is it discontinued?
- or is this just all versions covered in my download area - are there any newer versions than, say, 3.0.9? I don't think so, according to what I found here in the forum, but than again, I might be wrong...

Thanks for any help that might sort things out for me,

cheers
snafu
snafu
 
Posts: 6
Joined: Sun May 21, 2017 7:58 pm

Re: Any info on Flowstone versioning?

Postby Spogg » Tue Jun 11, 2019 8:48 am

Welcome back on board Mr Snafu! :D

The best version to use at the moment is widely agreed to be 3.06 so you should be ok.
Ages ago I downgraded from 3.08.1 to 3.06 and never looked back. Faster and more stable you see, and fully compatible with 3.08.1 schematics and toolbox.
FlowStone 4 with x64 support is being developed and coming on really well, but it’s not worth paying for upgrade cover at this point because we don’t have a release date yet for FS4.

Please avoid the 3.09 betas at all costs; they are really buggy.

Have fun!

Spogg
User avatar
Spogg
 
Posts: 2244
Joined: Thu Nov 20, 2014 4:24 pm
Location: Birmingham, England

Re: Any info on Flowstone versioning?

Postby martinvicanek » Tue Jun 11, 2019 10:27 am

3.0.8.1 is supposed to have some ASM extensions compared to 3.0.6.
User avatar
martinvicanek
 
Posts: 954
Joined: Sat Jun 22, 2013 8:28 pm

Re: Any info on Flowstone versioning?

Postby Spogg » Tue Jun 11, 2019 11:34 am

That’s new info for me Martin! :o
Do we know what’s been added? So far I’ve had no problems with anybody’s ASM code…

Cheers

Spogg
User avatar
Spogg
 
Posts: 2244
Joined: Thu Nov 20, 2014 4:24 pm
Location: Birmingham, England

Re: Any info on Flowstone versioning?

Postby martinvicanek » Tue Jun 11, 2019 12:06 pm

User avatar
martinvicanek
 
Posts: 954
Joined: Sat Jun 22, 2013 8:28 pm

Re: Any info on Flowstone versioning?

Postby snafu » Tue Jun 11, 2019 1:21 pm

Thank you very much, Mr. Spogg :D

Flowstone is a really cool tool, and I came across many (with different purposes though), but Flowstone must be the most impressive one.

Thanks for helping out!

kind regards
snafu
snafu
 
Posts: 6
Joined: Sun May 21, 2017 7:58 pm

Re: Any info on Flowstone versioning?

Postby Spogg » Tue Jun 11, 2019 5:09 pm

@Martin

Thanks for that link. I guess I've been lucky with other people's ASM code then. So far. :?
Did you personanlly make use of any of these new opcodes?

If I get one that doesn't work for me I can always briefly re-install 3.08 I guess.

Cheers

Spogg
User avatar
Spogg
 
Posts: 2244
Joined: Thu Nov 20, 2014 4:24 pm
Location: Birmingham, England

Re: Any info on Flowstone versioning?

Postby martinvicanek » Thu Jun 13, 2019 3:29 am

Spogg wrote:@Martin
Did you personanlly make use of any of these new opcodes?

I'm afraid I use them alll the time. Usually my schematics don't work with FS 3.0.6 but they don't crash either so it may not be obvious.
User avatar
martinvicanek
 
Posts: 954
Joined: Sat Jun 22, 2013 8:28 pm

Re: Any info on Flowstone versioning?

Postby Spogg » Thu Jun 13, 2019 7:49 am

That’s quite a worry Martin. :?

Would it be safe to assume that if one of yours does work then it’s ok in 3.06. Or might it be that something can partially work?

Cheers

Spogg
User avatar
Spogg
 
Posts: 2244
Joined: Thu Nov 20, 2014 4:24 pm
Location: Birmingham, England

Re: Any info on Flowstone versioning?

Postby tulamide » Thu Jun 13, 2019 10:48 am

Spogg wrote:If I get one that doesn't work for me I can always briefly re-install 3.08 I guess.

I wouldn't advise to go back to a version with issues (btw, the 3.0.9 betas are based on 3.0.8.1) just because Martin refuses to work with 3.0.6. He is also the one that regularly reports a lot of crashes with his version ;)
tulamide
 
Posts: 1968
Joined: Sat Jun 21, 2014 2:48 pm
Location: Germany

Next

Return to General

Who is online

Users browsing this forum: Google [Bot] and 11 guests

cron