Support

If you have a problem or need to report a bug please email : support@dsprobotics.com

There are 3 sections to this support area:

DOWNLOADS: access to product manuals, support files and drivers

HELP & INFORMATION: tutorials and example files for learning or finding pre-made modules for your projects

USER FORUMS: meet with other users and exchange ideas, you can also get help and assistance here

Analyser Bug

DSP related issues, mathematics, processing and techniques

Analyser Bug

Postby Tepeix » Sat Dec 03, 2022 12:55 am

Just find this strange bug with the analyser in 3.6.

Let's say i have a filter. I want to make a visual of the frequency curve while i use this filter.
So i make a copy of my filter, feed it with the same control knobs and use an analyser with the copy.

But this bypass the first code filter.. Just because the green control value are connected to the same code..

Edit : Maybe the example will seams to work, when all code restart it take the good value.
But if the controls are changed it will keep the same sound..
Attachments
Analyzer bug.fsm
(119.29 KiB) Downloaded 56 times
Tepeix
 
Posts: 214
Joined: Sat Oct 16, 2021 3:11 pm

Re: Analyser Bug

Postby Tepeix » Sat Dec 03, 2022 3:25 pm

I find a fix. Using a sample and hold and a tick to transmit the controls seams to works.
But to be sure, i add a trigger pulse that delay the tick coming from the knobs to update the analyser.

Maybe the graph prim could also be used instead of the analyser, but needing to build some code to use it with an impulse..
Attachments
Fix analyser.png
Fix analyser.png (66.41 KiB) Viewed 1443 times
Analyzer no bug.fsm
(95.88 KiB) Downloaded 58 times
Tepeix
 
Posts: 214
Joined: Sat Oct 16, 2021 3:11 pm


Return to DSP

Who is online

Users browsing this forum: No registered users and 4 guests

cron